CRS#004 - How to Install ATG 11.0 Commerce Reference Store (CRS) on Windows? - Part IV





Part IV - Additional Configuration and Server Startup


1. Additional ATG Configuration

a. Open DYNAMO_HOME/servers/atg_publishing_lockserver/localconfig/atg/search folder.
b. Create a file SynchronizationInvoker.properties
c. Add the following properties and save the file.
       host = localhost
    port = 8860
d. Open the file 
DYNAMO_HOME/servers/atg_publishing_lockserver/localconfig/atg/endeca/ApplicationConfiguration.properties
f. Add the following property and save the file.
    keyToApplicationName=default=CRS

2. Additional Weblogic Configuration

a. Open Weblogic Admin Server (http://localhost:7001/console) and logic with your weblogic credentials (weblogic/Welcome1)
b. Under the Domain Services on the left, click on "atg11".
c. Click on JTA tab. 
d. Set the "Timeout Settings" value to "1800"
e. Again, Under "atg11" -> "Services" click "Data Sources".


f. Click on ATGProductionDS. Click on Connection Pool tab.
g. Scroll down, and set the "Maximum Capacity" value to 600. Click Save.
h. Repeat the same process for ATGPublishingDS, ATGSwitchingDS_A, ATGSwitchingDS_B

3. Starting the Servers

a. Open CMD
b. Change the directory to your weblogic domain's bin folder
[cd D:\Oracle\Middleware\domains\atg11\bin]
c. Type the command: startManagedWeblogic.cmd atg_production_lockserver
to start the production server.
d. The startup window will pause for weblogic username and password. Type-in weblogic and press enter. Then type Welcome1 as password and press enter.
e. Let the server start. 
f. You can hit the production server by URL: http://localhost:7003/dyn/admin
g. Firstly, the system will ask for dyn/admin password. Type-in admin/Welcome1
h. It will again ask for a username/password for weblogic-level authentication. Type-in weblogic/Welcome1
i. This will open dyn/admin for your server. Your dyn/admin page will look like:



If it does not look like above and gives the following ERROR:



Please follow the steps HERE (opens in a new window) to fix this issue.  

Similarly, the command at step (c) can be modified to startManagedWeblogic.cmd atg_publishing_lockserver for starting the publishing server.
You can access dyn/admin of publishing server by URL: http://localhost:7103/dyn/admin
You can access BCC by URL: http://localhost:7103/atg/bcc [Credentials: admin/Welcome1]

4. Remove weblogic password during server startup

In the Step#3(d) Server asks for weblogic credentials, which could be a bit annoying. To remove this, you can follow the below steps:-
a. Browse to the weblogic domains directory/atg11/servers [e.g. D:\Oracle\Middleware\domains\atg11\servers]
b. Open the folder AdminServer.
c. Copy the folder named "security".
d. Come back to the "servers" folder.
e. open "atg_production_lockserver" folder and paste the copied folder named security.
f. do the same for "atg_publishing_lockserver".
g. Now start the servers using steps 3(a) to 3(c). The server will start without asking for any user intervention.

5. Run a Full Deployment

a. Start both; publishing and production servers (using different cmd windows)
b. Open BCC using the URL: http://localhost:7103/atg/bcc
c. You should see a screen like this




d. Enter the username/password as admin/Welcome1 and login.
e. In the left panel, under "Content Administration", click "CA Console"
f. A new page opens. Click "Configuration" in the left panel.
g. Again, a new page will open.
h. On Extreme right, there will be a button "Add Site". Click on it.
i. Enter the site name as "production", select "Flag Agents Only (data already imported to site)" and "Workflow target".




j. At the bottom, there will be two combo boxes, with repository names. You have to map left repositories to the right. To do a selection, select a repository on the left, select a repository on the right and click "Add". This will add the combination. 
All of the repositories on the left side should be mapped to a repository on the right.
After the mapping, it should look like:-




k. Click on "Save Changes" at the bottom.
l. Click on "Agents" tab. On the extreme right click "Add Agent to Site".
m. Write the agent name as "ProdAgent" and Transport URL as rmi://localhost:8860/atg/epub/AgentTransport
n. Check the "essential" checkbox.
o. Click on the double-right button between the combo-boxes of File Systems.
p. Click on Save Changes. After saving, the "Agents" tab should look like:-



q. Click on "Back to deployment administration configuration" on the top. Next, click on "Make Changes Live" button.
r. Select the "Flag Agents Only (data already imported to site)" and click "Make Changes Live".
s. Click on "Overview" on left side, and then click on "Production".
t. BCC will display the progress of your deployment. It may be fast so some of you might not see it.




u. After this deployment, Endeca Baseline Indexing automatically starts. To check the progress, open the Production server's dyn/admin [http://localhost:7003/dyn/admin]. Enter the username and password as admin/Welcome1 and then weblogic/Welcome1 for subsequent prompts.

h. Search for the component /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin. Wait for the status when all of the sections are "COMPLETED". If this is not started (all fields show PENDING), you can click "Baseline Index" button manually. Check on "Auto Refresh" checkbox, to see frequent updates.

i. Once this is done, you have to run set_templates and promote_content script.
Go to D:/Endeca/Apps/CRS/control and double click on set_templates.bat and thereafter successful execution, run promote_content.bat

j. Now access the storefront application using http://localhost:7003/crs

Now, let us move on to creating a new ATG Module on top of CRS for our practice! Grab-on as it is now going to be very interesting!







5 comments:

  1. Hi Monis,

    while running Baseline Indexing I got following error
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin --- atg.repository.search.indexing.IndexingException: TaskId(SCRIPT,CRS,BaselineUpdate) has failed.
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.eacclient.ScriptRunner.waitForScript(ScriptRunner.java:449)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.eacclient.ScriptIndexable.runUpdateScript(ScriptIndexable.java:292)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.eacclient.ScriptIndexable.performBaselineUpdate(ScriptIndexable.java:223)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.index.admin.IndexingTask.doTask(IndexingTask.java:421)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.index.admin.IndexingTask.performTask(IndexingTask.java:364)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.endeca.index.admin.IndexingPhase$IndexingTaskJob.invoke(IndexingPhase.java:476)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin at atg.common.util.ThreadDispatcherThread.run(ThreadDispatcherThread.java:178)
    **** Error Fri Jan 13 11:02:01 EST 2017 1484323321136 /atg/commerce/endeca/index/ProductCatalogSimpleIndexingAdmin


    Any Help

    ReplyDelete
    Replies
    1. 1. Make sure your endeca server is running. If not, start the Endeca Server and retry indexing.
      You can go to ToolsAndFrameworks directory and run "run.bat"
      D:\Endeca\ToolsAndFrameworks\11.0.0\server\bin

      2. If endeca server is running, and you are still getting this issue, you might have to re-initialize the Endeca App.
      Open cmd as administrator, go to the location where your endeca app is installed. Go inside the control folder and run "initialize_services.bat".
      [D:\Endeca\Apps\CRS\control\initialize_services.bat]
      Now restart your endeca server and re-run indexing.

      3. If you are still facing the issue, shut down endeca server, delete the "CRS" folder in the Endeca\Apps folder. Open CIM and re-create and deploy endeca application.

      Hope this helps.

      Delete
    2. Thanks Monis. It worked

      Delete
  2. Hi Monis.
    I am still getting Error getting Compliled Page while opening dyn admin. It is redirecting me too change password page. Can you please let me know solution

    ReplyDelete
    Replies
    1. Change the password and then change it back. It should work.

      Delete

Subscribe

Get All The Latest Updates Delivered Straight Into Your Inbox For Free!

Flickr